summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2015-10-21 15:08:30 (GMT)
committerBrad King <brad.king@kitware.com>2015-10-28 12:44:48 (GMT)
commit45cd9e63371ae09b6ad9dbc27ac4d36c19b357af (patch)
treecfb52a2451629c46cff566a75d72c60fc1a10e4e /CMakeLists.txt
parentc09acf4fdd961a8ba9a27f9af2800e9262cd18be (diff)
downloadCMake-45cd9e63371ae09b6ad9dbc27ac4d36c19b357af.zip
CMake-45cd9e63371ae09b6ad9dbc27ac4d36c19b357af.tar.gz
CMake-45cd9e63371ae09b6ad9dbc27ac4d36c19b357af.tar.bz2
Update libarchive configuration within CMake
Hard-code libarchive build options to the way CMake needs them. Set them as internal cache entries so users do not see them when building CMake.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c96f68b..ebee14b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -372,12 +372,14 @@ macro (CMAKE_BUILD_UTILITIES)
set(ENABLE_LZMA ON CACHE INTERNAL "Enable the use of the system found LZMA library if found")
set(ENABLE_ZLIB ON CACHE INTERNAL "Enable the use of the system found ZLIB library if found")
set(ENABLE_BZip2 ON CACHE INTERNAL "Enable the use of the system found BZip2 library if found")
+ set(ENABLE_LIBXML2 OFF CACHE INTERNAL "Enable the use of the system found libxml2 library if found")
set(ENABLE_EXPAT OFF CACHE INTERNAL "Enable the use of the system found EXPAT library if found")
set(ENABLE_PCREPOSIX OFF CACHE INTERNAL "Enable the use of the system found PCREPOSIX library if found")
set(ENABLE_LibGCC OFF CACHE INTERNAL "Enable the use of the system found LibGCC library if found")
set(ENABLE_XATTR OFF CACHE INTERNAL "Enable extended attribute support")
set(ENABLE_ACL OFF CACHE INTERNAL "Enable ACL support")
set(ENABLE_ICONV OFF CACHE INTERNAL "Enable iconv support")
+ set(ENABLE_CNG OFF CACHE INTERNAL "Enable the use of CNG(Crypto Next Generation)")
add_subdirectory(Utilities/cmlibarchive)
CMAKE_SET_TARGET_FOLDER(cmlibarchive "Utilities/3rdParty")
set(CMAKE_TAR_LIBRARIES cmlibarchive ${BZIP2_LIBRARIES})