summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2008-04-04 20:02:50 (GMT)
committerBill Hoffman <bill.hoffman@kitware.com>2008-04-04 20:02:50 (GMT)
commit45ce11a0757a1006a235f34637892115ffeae66e (patch)
treebe7370a18622502f98d774b00cd5606f3fa2ff72 /CMakeLists.txt
parentd1c660d49550af6f174cbfac4ce81bd7d7ce7a75 (diff)
downloadCMake-45ce11a0757a1006a235f34637892115ffeae66e.zip
CMake-45ce11a0757a1006a235f34637892115ffeae66e.tar.gz
CMake-45ce11a0757a1006a235f34637892115ffeae66e.tar.bz2
ENH: install the mac application bundle into /Applications directly with no enclosing folder
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 5 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 596c8f4..a54953d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -417,12 +417,13 @@ ENDIF(BUILD_CursesDialog)
IF(BUILD_QtDialog)
IF(APPLE)
- SET(CMAKE_INSTALL_SUBDIR
+ SET(CMAKE_BUNDLE_NAME
"CMake ${CMake_VERSION_MAJOR}.${CMake_VERSION_MINOR}-${CMake_VERSION_PATCH}")
IF(CMake_VERSION_DATE)
- SET(CMAKE_INSTALL_SUBDIR
+ SET(CMAKE_BUNDLE_NAME
"CMake ${CMake_VERSION_MAJOR}.${CMake_VERSION_MINOR}-${CMake_VERSION_DATE}")
ENDIF(CMake_VERSION_DATE)
+ SET(CMAKE_BUNDLE_LOCATION "${CMAKE_INSTALL_PREFIX}")
# make sure CMAKE_INSTALL_PREFIX ends in /
STRING(LENGTH "${CMAKE_INSTALL_PREFIX}" LEN)
MATH(EXPR LEN "${LEN} -1" )
@@ -430,8 +431,8 @@ IF(BUILD_QtDialog)
IF(NOT "${ENDCH}" STREQUAL "/")
SET(CMAKE_INSTALL_PREFIX "${CMAKE_INSTALL_PREFIX}/")
ENDIF(NOT "${ENDCH}" STREQUAL "/")
- SET(CMAKE_BUNDLE_LOCATION "${CMAKE_INSTALL_PREFIX}${CMAKE_INSTALL_SUBDIR}")
- SET(CMAKE_INSTALL_PREFIX "${CMAKE_INSTALL_PREFIX}${CMAKE_INSTALL_SUBDIR}/cmake-gui.app/Contents")
+ SET(CMAKE_INSTALL_PREFIX
+ "${CMAKE_INSTALL_PREFIX}${CMAKE_BUNDLE_NAME}.app/Contents")
ENDIF(APPLE)
SET(QT_NEED_RPATH FALSE)