summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2013-10-09 14:24:34 (GMT)
committerCMake Topic Stage <kwrobot@kitware.com>2013-10-09 14:24:34 (GMT)
commit5925e34107a1571a16e940bea2fcc88d8d3df3e1 (patch)
treef6d09f0796aae1ac8a4f32a464337f5371b1e218 /CMakeLists.txt
parentbe9d289fcef487753a5c88268e9ed4262e39633b (diff)
parentdcf1b645691a1d31cbbad78a9c6c9dca8d472346 (diff)
downloadCMake-5925e34107a1571a16e940bea2fcc88d8d3df3e1.zip
CMake-5925e34107a1571a16e940bea2fcc88d8d3df3e1.tar.gz
CMake-5925e34107a1571a16e940bea2fcc88d8d3df3e1.tar.bz2
Merge topic 'osx-cmake-app-info-plist'
dcf1b64 OS X: Set CMake.app bundle Info.plist fields (#11694)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 77b4604..b64b6a9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -532,8 +532,9 @@ endif()
if(BUILD_QtDialog)
if(APPLE)
- set(CMAKE_BUNDLE_NAME
- "CMake ${CMake_VERSION_MAJOR}.${CMake_VERSION_MINOR}-${CMake_VERSION_PATCH}")
+ set(CMAKE_BUNDLE_VERSION
+ "${CMake_VERSION_MAJOR}.${CMake_VERSION_MINOR}.${CMake_VERSION_PATCH}")
+ set(CMAKE_BUNDLE_NAME "CMake ${CMAKE_BUNDLE_VERSION}")
set(CMAKE_BUNDLE_LOCATION "${CMAKE_INSTALL_PREFIX}")
# make sure CMAKE_INSTALL_PREFIX ends in /
string(LENGTH "${CMAKE_INSTALL_PREFIX}" LEN)