summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2014-09-09 13:09:57 (GMT)
committerNils Gladitz <nilsgladitz@gmail.com>2014-09-11 19:23:24 (GMT)
commit858d5a0b3e52dbae635fac5a6944fba23a362f5b (patch)
tree76f2be038609faeb88abfb1d02826aec6250d659 /CMakeLists.txt
parente177e7affb10fc25b71d4c9d9796c9df7fcdb800 (diff)
downloadCMake-858d5a0b3e52dbae635fac5a6944fba23a362f5b.zip
CMake-858d5a0b3e52dbae635fac5a6944fba23a362f5b.tar.gz
CMake-858d5a0b3e52dbae635fac5a6944fba23a362f5b.tar.bz2
Fix if() checks of CMAKE_SYSTEM_NAME on Cygwin
The CMAKE_SYSTEM_NAME is "CYGWIN", but we also define a variable named "CYGWIN" to "1". Avoid allowing if() to expand the "CYGWIN" string as a variable.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 54aad83..14f60ae 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -381,7 +381,7 @@ macro (CMAKE_BUILD_UTILITIES)
# Use curses?
if (UNIX)
# there is a bug in the Syllable libraries which makes linking ccmake fail, Alex
- if(NOT "${CMAKE_SYSTEM_NAME}" MATCHES syllable)
+ if(NOT CMAKE_SYSTEM_NAME MATCHES syllable)
set(CURSES_NEED_NCURSES TRUE)
find_package(Curses QUIET)
if (CURSES_LIBRARY)