summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2014-03-03 17:39:10 (GMT)
committerBrad King <brad.king@kitware.com>2014-03-03 20:26:46 (GMT)
commitdaf0a5fedebb2dac66ac26516eeeff502ddcf432 (patch)
tree8e51897a6f69cfc5c21c4d664d245b7472d94352 /CMakeLists.txt
parente5096312378f97cca24f4190082b3b8991812608 (diff)
downloadCMake-daf0a5fedebb2dac66ac26516eeeff502ddcf432.zip
CMake-daf0a5fedebb2dac66ac26516eeeff502ddcf432.tar.gz
CMake-daf0a5fedebb2dac66ac26516eeeff502ddcf432.tar.bz2
Tests: Drop CMAKE_TEST_GENERATOR and CMAKE_TEST_MAKEPROGRAM options
Drop the option to test with a different generator and make program than was used to build. This was used only to test support for the Open Watcom compiler which at one time could not build CMake. Instead we will allow CMake to be configured to skip building binaries and just run the test suite using an external CMake (in a future change). For now leave the two option variables hard-coded to the old option defaults until code can be updated to stop using them.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 2 insertions, 11 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9e1e7c3..4c2c20b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -114,17 +114,8 @@ endif()
#-----------------------------------------------------------------------
macro(CMAKE_SETUP_TESTING)
if(BUILD_TESTING)
- set(CMAKE_TEST_GENERATOR "" CACHE STRING
- "Generator used when running tests")
- set(CMAKE_TEST_MAKEPROGRAM "" CACHE FILEPATH
- "Generator used when running tests")
- if(NOT CMAKE_TEST_GENERATOR)
- set(CMAKE_TEST_GENERATOR "${CMAKE_GENERATOR}")
- set(CMAKE_TEST_GENERATOR_TOOLSET "${CMAKE_GENERATOR_TOOLSET}")
- else()
- set(CMAKE_TEST_DIFFERENT_GENERATOR TRUE)
- set(CMAKE_TEST_GENERATOR_TOOLSET "")
- endif()
+ set(CMAKE_TEST_GENERATOR "${CMAKE_GENERATOR}")
+ set(CMAKE_TEST_GENERATOR_TOOLSET "${CMAKE_GENERATOR_TOOLSET}")
# Are we testing with the MSVC compiler?
set(CMAKE_TEST_MSVC 0)