summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Pfeifer <daniel@pfeifer-mail.de>2016-06-22 22:16:15 (GMT)
committerBrad King <brad.king@kitware.com>2016-06-27 14:37:40 (GMT)
commitea5477e43de4660343897e4669bc5809dc4ddabe (patch)
treea368c8573d3b2c24b713e059e87fa1895604eb39 /CMakeLists.txt
parent68bb74d9e651fd44ddeeb81caa59096dbf1f0605 (diff)
downloadCMake-ea5477e43de4660343897e4669bc5809dc4ddabe.zip
CMake-ea5477e43de4660343897e4669bc5809dc4ddabe.tar.gz
CMake-ea5477e43de4660343897e4669bc5809dc4ddabe.tar.bz2
Make C++ feature checks extensible
Turn the feature check for cxx11_unordered_map into a function such that we can use it for other features as well. Drop the 11 suffix, as we may want to check features from other standards.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5336208..ae5990e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -67,7 +67,7 @@ if(NOT DEFINED CMAKE_CXX_STANDARD AND NOT CMake_NO_CXX_STANDARD)
endif()
endif()
if(NOT CMake_TEST_EXTERNAL_CMAKE)
- include(${CMake_SOURCE_DIR}/Source/Checks/cm_cxx11_unordered_map.cmake)
+ include(${CMake_SOURCE_DIR}/Source/Checks/cm_cxx_features.cmake)
endif()
# option to set the internal encoding of CMake to UTF-8