summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2009-04-10 15:59:31 (GMT)
committerBill Hoffman <bill.hoffman@kitware.com>2009-04-10 15:59:31 (GMT)
commit5783d5aab1654ee185036b665b618f7310d9d3f9 (patch)
tree3c2718d7663f1dba5b70f244fcb162f6f7d0b04e /CMakeLists.txt
parent3c0e239346b24dd77269d5e69c531ca0af187569 (diff)
downloadCMake-5783d5aab1654ee185036b665b618f7310d9d3f9.zip
CMake-5783d5aab1654ee185036b665b618f7310d9d3f9.tar.gz
CMake-5783d5aab1654ee185036b665b618f7310d9d3f9.tar.bz2
ENH: allow for shared build of libcurl and fix build with openssl option (ssl tested on linux and windows
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d48bda2..9267f42 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -266,7 +266,10 @@ MACRO (CMAKE_BUILD_UTILITIES)
SET(CURL_SPECIAL_ZLIB_H ${CMAKE_ZLIB_HEADER})
SET(CURL_SPECIAL_LIBZ_INCLUDES ${CMAKE_ZLIB_INCLUDES})
SET(CURL_SPECIAL_LIBZ ${CMAKE_ZLIB_LIBRARIES})
- ADD_DEFINITIONS(-DCURL_STATICLIB)
+ OPTION(CMAKE_BUILD_CURL_SHARED "Should curl be built shared" FALSE)
+ IF(NOT CMAKE_BUILD_CURL_SHARED)
+ ADD_DEFINITIONS(-DCURL_STATICLIB)
+ ENDIF(NOT CMAKE_BUILD_CURL_SHARED)
SET(CMAKE_CURL_INCLUDES)
SET(CMAKE_CURL_LIBRARIES cmcurl)
IF(CMAKE_USE_NEW_CURL)