summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKen Martin <ken.martin@kitware.com>2001-08-28 20:06:52 (GMT)
committerKen Martin <ken.martin@kitware.com>2001-08-28 20:06:52 (GMT)
commit74ef4e4e583537b3d7a5a9e87bcb6e45238558d2 (patch)
tree1a75e5c2707324a669d2c31686b7fbcef39b299d /CMakeLists.txt
parentf85fc7cda1e6caa625eee71019bcb57c932ba0ab (diff)
downloadCMake-74ef4e4e583537b3d7a5a9e87bcb6e45238558d2.zip
CMake-74ef4e4e583537b3d7a5a9e87bcb6e45238558d2.tar.gz
CMake-74ef4e4e583537b3d7a5a9e87bcb6e45238558d2.tar.bz2
minor fix
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 93e27d4..a323468 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -6,7 +6,9 @@ SUBDIRS(Source Modules Templates)
INCLUDE (${CMAKE_ROOT}/Modules/Dart.cmake)
# use the ansi CXX compile flag for building cmake
-SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${CMAKE_ANSI_CXXFLAGS}")
+IF (CMAKE_ANSI_CXXFLAGS)
+ SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${CMAKE_ANSI_CXXFLAGS}")
+ENDIF (CMAKE_ANSI_CXXFLAGS)
# add some testing dependencies
IF(BUILD_TESTING)
IF (DART_ROOT)