summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2013-02-08 18:38:56 (GMT)
committerCMake Topic Stage <kwrobot@kitware.com>2013-02-08 18:38:56 (GMT)
commit7dab997771e4f496fd71a4e9c3abc26063c57c68 (patch)
treec591caee76cbcc3938e54823c2b06f30d6f698b0 /CMakeLists.txt
parent2cd362d19114e4b8a85c3c5179734d12416f4d72 (diff)
parent56ca8d4e6365d67901e0cff7f2bd99f174537a97 (diff)
downloadCMake-7dab997771e4f496fd71a4e9c3abc26063c57c68.zip
CMake-7dab997771e4f496fd71a4e9c3abc26063c57c68.tar.gz
CMake-7dab997771e4f496fd71a4e9c3abc26063c57c68.tar.bz2
Merge topic 'generator-toolset'
56ca8d4 Tests: Add generator toolset support f36c665 Tests: Consolidate ctest --build-and-test generator options c0debb1 Merge branch 'master' into generator-toolset daae0d2 ExternalProject: Propagate the generator toolset e3841cf CTest: Add options to set generator toolset f980a80 Xcode: Implement generator toolset selection (#9831, #13802) 650c647 VS: Implement generator toolset selection (#10722, #13774) 4fd5342 CMake: Add -T option to choose a generator toolset 118c32f Merge branch 'xcode-duplicate-flags-13354' into generator-toolset cf8645e Tests: Run ctest custom commands with VERBATIM 5b2fba5 ExternalProject: Simplify CMake command line generation
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e84f898..75d372d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -122,9 +122,11 @@ macro(CMAKE_SETUP_TESTING)
"Generator used when running tests")
if(NOT CMAKE_TEST_GENERATOR)
set(CMAKE_TEST_GENERATOR "${CMAKE_GENERATOR}")
+ set(CMAKE_TEST_GENERATOR_TOOLSET "${CMAKE_GENERATOR_TOOLSET}")
set(CMAKE_TEST_MAKEPROGRAM "${MAKEPROGRAM}")
else()
set(CMAKE_TEST_DIFFERENT_GENERATOR TRUE)
+ set(CMAKE_TEST_GENERATOR_TOOLSET "")
endif()
# Are we testing with the MSVC compiler?