summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2013-02-05 21:10:36 (GMT)
committerBrad King <brad.king@kitware.com>2013-02-07 16:09:56 (GMT)
commit56ca8d4e6365d67901e0cff7f2bd99f174537a97 (patch)
tree17473ad1dd7b67c915b53a17b0bca243b500cc45 /CMakeLists.txt
parentf36c665df80e8e3f4eca0fed28b5d1c3df739552 (diff)
downloadCMake-56ca8d4e6365d67901e0cff7f2bd99f174537a97.zip
CMake-56ca8d4e6365d67901e0cff7f2bd99f174537a97.tar.gz
CMake-56ca8d4e6365d67901e0cff7f2bd99f174537a97.tar.bz2
Tests: Add generator toolset support
Propagate CMAKE_GENERATOR_TOOLSET through the test hierarchy so that all tests can build with the selected generator toolset, if any.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e84f898..75d372d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -122,9 +122,11 @@ macro(CMAKE_SETUP_TESTING)
"Generator used when running tests")
if(NOT CMAKE_TEST_GENERATOR)
set(CMAKE_TEST_GENERATOR "${CMAKE_GENERATOR}")
+ set(CMAKE_TEST_GENERATOR_TOOLSET "${CMAKE_GENERATOR_TOOLSET}")
set(CMAKE_TEST_MAKEPROGRAM "${MAKEPROGRAM}")
else()
set(CMAKE_TEST_DIFFERENT_GENERATOR TRUE)
+ set(CMAKE_TEST_GENERATOR_TOOLSET "")
endif()
# Are we testing with the MSVC compiler?