summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Cole <david.cole@kitware.com>2011-11-15 19:39:12 (GMT)
committerCMake Topic Stage <kwrobot@kitware.com>2011-11-15 19:39:12 (GMT)
commit6ac35e5cb3538c40bbfa662c6485684c26c7297d (patch)
treead8a9ed99bbb522c0d96f6f4d342056815c0dc13 /CMakeLists.txt
parentc616f46fc56ae1433b6dcc54270b652f99fb7904 (diff)
parent5be0e92218f4f82766389d7c8bb3193d98a09a87 (diff)
downloadCMake-6ac35e5cb3538c40bbfa662c6485684c26c7297d.zip
CMake-6ac35e5cb3538c40bbfa662c6485684c26c7297d.tar.gz
CMake-6ac35e5cb3538c40bbfa662c6485684c26c7297d.tar.bz2
Merge topic 'import-KWIML'
5be0e92 Merge branch 'upstream-kwiml' into import-KWIML a8f6159 KWIML: Create test output dir for Xcode 33fff24 KWIML: No INT_SCN*8 on Intel for Windows bcc06d4 KWIML: No INT_SCN*8 on SunPro compiler 6d12ab3 KWIML: Suppress printf/scanf format warnings in test 553acec KWIML: Avoid redefining _CRT_SECURE_NO_DEPRECATE in test.h 93cebca Configure KWIML inside CMake as cmIML b2975ad Merge branch 'upstream-kwiml' into import-KWIML 831bade KWIML: The Kitware Information Macro Library
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a586764..5705e6e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -214,6 +214,12 @@ ENDMACRO(CMAKE_SET_TARGET_FOLDER)
#-----------------------------------------------------------------------
MACRO (CMAKE_BUILD_UTILITIES)
#---------------------------------------------------------------------
+ # Create the KWIML library for CMake.
+ SET(KWIML cmIML)
+ SET(KWIML_HEADER_ROOT ${CMake_BINARY_DIR}/Utilities)
+ ADD_SUBDIRECTORY(Utilities/KWIML)
+
+ #---------------------------------------------------------------------
# Create the kwsys library for CMake.
SET(KWSYS_NAMESPACE cmsys)
SET(KWSYS_USE_SystemTools 1)