summaryrefslogtreecommitdiffstats
path: root/Docs/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2013-08-26 15:50:08 (GMT)
committerBrad King <brad.king@kitware.com>2013-08-26 15:54:07 (GMT)
commitdf62f64db72b6f00657e9e739e1e117639dea9da (patch)
tree88a64dd1f0579ab27b18b0911c817c1e556b3259 /Docs/CMakeLists.txt
parent8da09f6ee1a59cbef6327d2a88ab8ba5f8b29b1a (diff)
downloadCMake-df62f64db72b6f00657e9e739e1e117639dea9da.zip
CMake-df62f64db72b6f00657e9e739e1e117639dea9da.tar.gz
CMake-df62f64db72b6f00657e9e739e1e117639dea9da.tar.bz2
Clean up install rules of CMake itself (#14371)
Ensure CMAKE_DATA_DIR, CMAKE_DOC_DIR, and CMAKE_MAN_DIR are always relative paths in CMake code, and set defaults accordingly. Use the install() command instead of install_files() and install_targets(). This is more modern and also avoids stripping of the first character from user-specified destinations. While at it, fix the default destinations reported in the bootstrap help.
Diffstat (limited to 'Docs/CMakeLists.txt')
-rw-r--r--Docs/CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/Docs/CMakeLists.txt b/Docs/CMakeLists.txt
index a5e91c9..34090d2 100644
--- a/Docs/CMakeLists.txt
+++ b/Docs/CMakeLists.txt
@@ -1,4 +1,3 @@
-string(REGEX REPLACE "^/(.*)" "\\1" REL_CMAKE_DATA_DIR "${CMAKE_DATA_DIR}")
-install(FILES cmake-help.vim cmake-indent.vim cmake-syntax.vim DESTINATION ${REL_CMAKE_DATA_DIR}/editors/vim)
-install(FILES cmake-mode.el DESTINATION ${REL_CMAKE_DATA_DIR}/editors/emacs)
+install(FILES cmake-help.vim cmake-indent.vim cmake-syntax.vim DESTINATION ${CMAKE_DATA_DIR}/editors/vim)
+install(FILES cmake-mode.el DESTINATION ${CMAKE_DATA_DIR}/editors/emacs)
add_subdirectory (bash-completion)