summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2003-08-21 20:22:23 (GMT)
committerBill Hoffman <bill.hoffman@kitware.com>2003-08-21 20:22:23 (GMT)
commita413160fecc73bf61fccff9b74d6e18349eeb861 (patch)
tree5cbc485d7850ebc5200d8f094ba1559b1bc202e8 /Source/CMakeLists.txt
parent0270b60b8f32c0da9bbe66ebee6aea92ab177c3c (diff)
downloadCMake-a413160fecc73bf61fccff9b74d6e18349eeb861.zip
CMake-a413160fecc73bf61fccff9b74d6e18349eeb861.tar.gz
CMake-a413160fecc73bf61fccff9b74d6e18349eeb861.tar.bz2
ENH: add the unix makefile generator as an option from the windows GUI, this builds with mingw, cygwin, and combinations of make cl, bcc32
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt45
1 files changed, 25 insertions, 20 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 35de882..b06883a 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -65,22 +65,25 @@ ENDIF (APPLE)
IF (WIN32)
IF(NOT UNIX)
SET(SRCS ${SRCS}
- cmGlobalBorlandMakefileGenerator.cxx
- cmGlobalNMakeMakefileGenerator.cxx
- cmGlobalVisualStudio6Generator.cxx
- cmLocalVisualStudio6Generator.cxx
- cmGlobalVisualStudio71Generator.cxx
- cmGlobalVisualStudio7Generator.cxx
- cmLocalVisualStudio7Generator.cxx
- cmGlobalBorlandMakefileGenerator.h
- cmGlobalNMakeMakefileGenerator.h
- cmGlobalVisualStudio6Generator.h
- cmLocalVisualStudio6Generator.h
- cmGlobalVisualStudio7Generator.h
- cmLocalVisualStudio7Generator.h
- cmWin32ProcessExecution.cxx
- cmWin32ProcessExecution.h
- )
+ cmGlobalBorlandMakefileGenerator.cxx
+ cmGlobalNMakeMakefileGenerator.cxx
+ cmGlobalVisualStudio6Generator.cxx
+ cmLocalVisualStudio6Generator.cxx
+ cmGlobalBorlandMakefileGenerator.h
+ cmGlobalNMakeMakefileGenerator.h
+ cmGlobalVisualStudio6Generator.h
+ cmLocalVisualStudio6Generator.h
+ cmWin32ProcessExecution.cxx
+ cmWin32ProcessExecution.h
+ )
+ IF(NOT MINGW)
+ SET(SRCS ${SRCS}
+ cmGlobalVisualStudio7Generator.h
+ cmLocalVisualStudio7Generator.h
+ cmGlobalVisualStudio71Generator.cxx
+ cmGlobalVisualStudio7Generator.cxx
+ cmLocalVisualStudio7Generator.cxx)
+ ENDIF(NOT MINGW)
ENDIF(NOT UNIX)
ENDIF (WIN32)
@@ -95,10 +98,12 @@ LINK_DIRECTORIES(${CMake_BINARY_DIR}/Source)
IF (WIN32)
IF(NOT UNIX)
IF( NOT BORLAND )
- LINK_LIBRARIES( rpcrt4.lib )
- ADD_EXECUTABLE(cmw9xcom cmw9xcom.cxx)
- TARGET_LINK_LIBRARIES(cmw9xcom CMakeLib)
- SUBDIRS(MFCDialog)
+ IF(NOT MINGW )
+ LINK_LIBRARIES( rpcrt4.lib )
+ ADD_EXECUTABLE(cmw9xcom cmw9xcom.cxx)
+ TARGET_LINK_LIBRARIES(cmw9xcom CMakeLib)
+ SUBDIRS(MFCDialog)
+ ENDIF(NOT MINGW )
ENDIF( NOT BORLAND )
ENDIF(NOT UNIX)
ENDIF (WIN32)