summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2001-06-20 20:49:09 (GMT)
committerBill Hoffman <bill.hoffman@kitware.com>2001-06-20 20:49:09 (GMT)
commit339bdd47b584a7e273bd488e21d95d241be3baaa (patch)
tree6585054fc78b2bcdb242571c8f282ee166c0782d /Source/CMakeLists.txt
parentadbae91cb5a5cb4cd33df273dd977791406ec339 (diff)
downloadCMake-339bdd47b584a7e273bd488e21d95d241be3baaa.zip
CMake-339bdd47b584a7e273bd488e21d95d241be3baaa.tar.gz
CMake-339bdd47b584a7e273bd488e21d95d241be3baaa.tar.bz2
ENH: boot strap mfc gui and support for MFC
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index a38e9af..6c38220 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -35,10 +35,14 @@ ADD_DEFINITIONS(-DCMAKE_BUILD_WITH_CMAKE)
IF (WIN32)
SOURCE_FILES(SRCS cmDSWWriter.cxx cmDSPWriter.cxx cmMSProjectGenerator.cxx)
-ELSE (WIN32)
- SOURCE_FILES(SRCS cmUnixMakefileGenerator.cxx)
+ IF(NOT UNIX)
+ SUBDIRS(MFCDialog)
+ ENDIF(NOT UNIX)
ENDIF (WIN32)
+SOURCE_FILES(SRCS cmUnixMakefileGenerator.cxx)
+
+
# create a library used by the command line and the GUI
ADD_LIBRARY(CMakeLib SRCS)
# always link in the library