summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorAndy Cedilnik <andy.cedilnik@kitware.com>2002-03-15 20:42:59 (GMT)
committerAndy Cedilnik <andy.cedilnik@kitware.com>2002-03-15 20:42:59 (GMT)
commit5bbae885693f74b50b1f4265d8ab32fe65288194 (patch)
tree55fc5a134bde8f54292155952273ac549c49ec12 /Source/CMakeLists.txt
parentc8924864fdcf66fcc62d4c6a95606ad200b7ba1a (diff)
downloadCMake-5bbae885693f74b50b1f4265d8ab32fe65288194.zip
CMake-5bbae885693f74b50b1f4265d8ab32fe65288194.tar.gz
CMake-5bbae885693f74b50b1f4265d8ab32fe65288194.tar.bz2
Add ccommand for executing commands on the system, so by using ADD_CUSTOM_COMMAND, you can make rules to do some system commands during build. Currently supported commands are copy and remove. Others will follow.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 1d658f1..a18d376 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -97,6 +97,7 @@ ADD_EXECUTABLE(cmake cmakemain)
ADD_EXECUTABLE(DumpDocumentation cmDumpDocumentation)
ADD_EXECUTABLE(ctest ctest.cxx cmSystemTools.cxx cmRegularExpression.cxx)
+ADD_EXECUTABLE(ccommand ccommand.cxx cmSystemTools.cxx cmMakefile.cxx)
CONFIGURE_FILE(
${CMake_SOURCE_DIR}/Source/cmaketest.h.in
@@ -149,5 +150,6 @@ INCLUDE (${CMAKE_SOURCE_DIR}/Source/LocalUserOptions.cmake OPTIONAL)
INSTALL_TARGETS(/bin cmake)
INSTALL_TARGETS(/bin ctest)
+INSTALL_TARGETS(/bin ccommand)
INSTALL_TARGETS(/bin cmaketest)