summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2001-10-03 19:49:52 (GMT)
committerBill Hoffman <bill.hoffman@kitware.com>2001-10-03 19:49:52 (GMT)
commit8f652aad2176055ff7f76e76fcb14389bafcc543 (patch)
tree27cf83147f35dafce3563197a5dc41836c5ca252 /Source/CMakeLists.txt
parente2eaa3efba61a39fcf5e69d0773d9c4aad653d84 (diff)
downloadCMake-8f652aad2176055ff7f76e76fcb14389bafcc543.zip
CMake-8f652aad2176055ff7f76e76fcb14389bafcc543.tar.gz
CMake-8f652aad2176055ff7f76e76fcb14389bafcc543.tar.bz2
ENH: fixes for borland compiler testing
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 2c4410b..f51f358 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -40,7 +40,10 @@ IF (WIN32)
SOURCE_FILES(SRCS cmDSWWriter.cxx cmDSPWriter.cxx cmMSProjectGenerator.cxx)
SOURCE_FILES(SRCS cmBorlandMakefileGenerator.cpp)
IF(NOT UNIX)
- SUBDIRS(MFCDialog)
+ IF( CMAKE_CXX_COMPILER MATCHES Borland )
+ ELSE (CMAKE_CXX_COMPILER MATCHES Borland )
+ SUBDIRS(MFCDialog)
+ ENDIF( CMAKE_CXX_COMPILER MATCHES Borland)
ENDIF(NOT UNIX)
ENDIF (WIN32)