summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorAndy Cedilnik <andy.cedilnik@kitware.com>2004-10-05 20:14:04 (GMT)
committerAndy Cedilnik <andy.cedilnik@kitware.com>2004-10-05 20:14:04 (GMT)
commit9e1288da106d663fc34824de36424c363df49f96 (patch)
treeb01703626726c10a606e2180bf610c4319f8acc5 /Source/CMakeLists.txt
parent16c839206a3ec70addd4012d703e86f0dad9f961 (diff)
downloadCMake-9e1288da106d663fc34824de36424c363df49f96.zip
CMake-9e1288da106d663fc34824de36424c363df49f96.tar.gz
CMake-9e1288da106d663fc34824de36424c363df49f96.tar.bz2
PERF: Several cleanups, and remove need for Curl directory to be in include path
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt7
1 files changed, 3 insertions, 4 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index fdfe6bf..0040cf6 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -127,16 +127,15 @@ ENDIF (UNIX)
TARGET_LINK_LIBRARIES(cmake CMakeLib)
TARGET_LINK_LIBRARIES(DumpDocumentation CMakeLib)
+ADD_EXECUTABLE(coverage coverage.cxx)
+TARGET_LINK_LIBRARIES(coverage CMakeLib)
+
IF(CMAKE_BUILD_WITH_CURL)
# Don't even look for this as we don't use that part of curl
# and linking in the the library can cause problems.
- SET(HAVE_LIBCRYPTO 0)
SUBDIRS(CTest)
SET(CMTEST_SRCS ${CMTEST_SRCS} CTest/cmCTestSubmit.cxx)
ADD_DEFINITIONS(-DHAVE_CURL)
- INCLUDE_DIRECTORIES(
- ${CMAKE_SOURCE_DIR}/Source/CTest/Curl
- )
ENDIF(CMAKE_BUILD_WITH_CURL)
ADD_EXECUTABLE(ctest ${CMTEST_SRCS})