summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2007-04-17 19:06:04 (GMT)
committerBrad King <brad.king@kitware.com>2007-04-17 19:06:04 (GMT)
commit84584e118468298199400cf1699fe72cafbe7491 (patch)
tree475664f211e39bc64cef27d5eb861dcdbc3a126c /Source/CMakeLists.txt
parent0164f2faae22b002482adbfb1168af8712b8b3b8 (diff)
downloadCMake-84584e118468298199400cf1699fe72cafbe7491.zip
CMake-84584e118468298199400cf1699fe72cafbe7491.tar.gz
CMake-84584e118468298199400cf1699fe72cafbe7491.tar.bz2
BUG: Disable Plugin test until it works everywhere.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index be55bb2..7f16987 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -986,6 +986,8 @@ IF(BUILD_TESTING)
--test-command executable
)
+ # Disable this test by default until it works everywhere.
+ IF(CMAKE_TEST_ENABLE_Plugin)
ADD_TEST(Plugin ${CMAKE_CTEST_COMMAND}
--build-and-test
"${CMake_SOURCE_DIR}/Tests/Plugin"
@@ -995,6 +997,7 @@ IF(BUILD_TESTING)
--build-makeprogram ${CMAKE_TEST_MAKEPROGRAM}
--build-two-config
--test-command bin/example)
+ ENDIF(CMAKE_TEST_ENABLE_Plugin)
IF(NOT CMAKE_TEST_DIFFERENT_GENERATOR)
ADD_TEST(kwsys ${CMAKE_CTEST_COMMAND}