summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorAndy Cedilnik <andy.cedilnik@kitware.com>2004-04-26 21:32:56 (GMT)
committerAndy Cedilnik <andy.cedilnik@kitware.com>2004-04-26 21:32:56 (GMT)
commitd6090a2395a2e8e0c506e62a95e0e9dd197c6572 (patch)
tree3030c69e7dcc93a84fe308a73db6b45044661d4b /Source/CMakeLists.txt
parent62fec96d993975775410ebc2dceaa65b03a12ae2 (diff)
downloadCMake-d6090a2395a2e8e0c506e62a95e0e9dd197c6572.zip
CMake-d6090a2395a2e8e0c506e62a95e0e9dd197c6572.tar.gz
CMake-d6090a2395a2e8e0c506e62a95e0e9dd197c6572.tar.bz2
ENH: When source file is in subdirectory put object file in subdirectory. Fixes Bug #290 - Source files in subdirectories should produce object files in subdirectories
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 13b2416..d38c37f 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -580,7 +580,9 @@ IF(BUILD_TESTING)
--build-generator ${CMAKE_GENERATOR}
--build-makeprogram ${MAKEPROGRAM}
--build-project SUBDIR
- --test-command test "${CMake_BINARY_DIR}/Tests/SubDir/ShouldBeHere"
+ --test-command test
+ "${CMake_BINARY_DIR}/Tests/SubDir/ShouldBeHere"
+ "${CMake_BINARY_DIR}/Tests/SubDir/testfromsubdir.o"
)
IF (APPLE)