summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2008-02-06 04:10:41 (GMT)
committerBrad King <brad.king@kitware.com>2008-02-06 04:10:41 (GMT)
commit523ddedac59756e485818a88c59949355c1b9267 (patch)
treee4d2a1c74ef039f76913981c9073f185e9c2b9fb /Source/CMakeLists.txt
parent5b9fccdc0e5e5e3b723f0375f95983b7950be933 (diff)
downloadCMake-523ddedac59756e485818a88c59949355c1b9267.zip
CMake-523ddedac59756e485818a88c59949355c1b9267.tar.gz
CMake-523ddedac59756e485818a88c59949355c1b9267.tar.bz2
ENH: Analyze inter-target dependencies to safely fix cycles
- Cycles may be formed among static libraries - Native build system should not have cycles in target deps - Create cmComputeTargetDepends to analyze dependencies - Identify conneced components and use them to fix deps - Diagnose cycles containing non-STATIC targets - Add debug mode property GLOBAL_DEPENDS_DEBUG_MODE - Use results in cmGlobalGenerator as target direct depends
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index a73f511..dc83ca3 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -91,6 +91,8 @@ SET(SRCS
cmComputeLinkDepends.h
cmComputeLinkInformation.cxx
cmComputeLinkInformation.h
+ cmComputeTargetDepends.h
+ cmComputeTargetDepends.cxx
cmCustomCommand.cxx
cmCustomCommand.h
cmDepends.cxx