summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2004-08-26 18:55:55 (GMT)
committerBill Hoffman <bill.hoffman@kitware.com>2004-08-26 18:55:55 (GMT)
commit66a08c10e5bd4b8eff58837cd58372a4dfdd19df (patch)
tree9d094b67d0899a3cebdfeba8b0280d374e7f25db /Source/CMakeLists.txt
parent7cdf5c4601ea2a791d35fafadd890508ce434c6f (diff)
downloadCMake-66a08c10e5bd4b8eff58837cd58372a4dfdd19df.zip
CMake-66a08c10e5bd4b8eff58837cd58372a4dfdd19df.tar.gz
CMake-66a08c10e5bd4b8eff58837cd58372a4dfdd19df.tar.bz2
ENH: more uniform approach to enable language, one step closer to being able to enable a language without modifing cmake source code
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 4f59aed..1a1fea0 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -119,6 +119,9 @@ TARGET_LINK_LIBRARIES(cmake CMakeLib)
TARGET_LINK_LIBRARIES(DumpDocumentation CMakeLib)
IF(CMAKE_BUILD_WITH_CURL)
+ # Don't even look for this as we don't use that part of curl
+ # and linking in the the library can cause problems.
+ SET(HAVE_LIBCRYPTO 0)
SUBDIRS(CTest)
SET(CMTEST_SRCS ${CMTEST_SRCS} CTest/cmCTestSubmit.cxx)
ADD_DEFINITIONS(-DHAVE_CURL)