summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2001-06-19 19:33:37 (GMT)
committerBill Hoffman <bill.hoffman@kitware.com>2001-06-19 19:33:37 (GMT)
commitd454811a63636b835483b6ddad7a36d16f9b75db (patch)
treeeaf3134a7d7338c05490b62387a6ac752d106862 /Source/CMakeLists.txt
parentf991ddd4ba29bd67059e5c2ebe108333e452bbe1 (diff)
downloadCMake-d454811a63636b835483b6ddad7a36d16f9b75db.zip
CMake-d454811a63636b835483b6ddad7a36d16f9b75db.tar.gz
CMake-d454811a63636b835483b6ddad7a36d16f9b75db.tar.bz2
ENH: add bootstrap support for building fltk
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt19
1 files changed, 17 insertions, 2 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index f8ef7e5..aec9fb9 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -1,3 +1,12 @@
+INCLUDE (${CMAKE_ROOT}/Modules/FindFLTK.cmake)
+
+
+IF(FLTK_LIBRARY)
+ IF(FLTK_INCLUDE_PATH)
+ SUBDIRS(FLTKDialog)
+ ENDIF(FLTK_INCLUDE_PATH)
+ENDIF(FLTK_LIBRARY)
+
SOURCE_FILES(SRCS
cmake
cmMakeDepend
@@ -13,7 +22,6 @@ cmCustomCommand
cmCacheManager
cmCableClassSet
cmSourceGroup
-cmakemain
)
IF (WIN32)
@@ -22,7 +30,14 @@ ELSE (WIN32)
SOURCE_FILES(SRCS cmUnixMakefileGenerator)
ENDIF (WIN32)
-ADD_EXECUTABLE(cmake SRCS)
+# create a library used by the command line and the GUI
+ADD_LIBRARY(CMakeLib SRCS)
+# always link in the library
+LINK_LIBRARIES(CMakeLib)
+# the library is found here
+LINK_DIRECTORIES(${CMAKE}/Sources)
+
+ADD_EXECUTABLE(cmake cmakemain)
ADD_TEST(burn cmake)