summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2003-07-24 14:58:40 (GMT)
committerBrad King <brad.king@kitware.com>2003-07-24 14:58:40 (GMT)
commit08441daded83d314c95016b1a6f7bb047b85e0f2 (patch)
tree9ced40f442855405d882bc06c2a3c494475a314d /Source/CMakeLists.txt
parent1a0ca7264885f953a8adbe90ae5d6b9dfdf9142c (diff)
downloadCMake-08441daded83d314c95016b1a6f7bb047b85e0f2.zip
CMake-08441daded83d314c95016b1a6f7bb047b85e0f2.tar.gz
CMake-08441daded83d314c95016b1a6f7bb047b85e0f2.tar.bz2
ENH: Added CommandLineTest to add coverage for command line arguments to cmake executables. This replaces the old DumpDocumentation test.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 38cafb6..552bbec 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -154,8 +154,10 @@ ADD_EXECUTABLE(cmaketest cmaketest.cxx)
TARGET_LINK_LIBRARIES(cmaketest CMakeLib)
IF(BUILD_TESTING)
- ADD_TEST(DumpDocumentation ${EXECUTABLE_OUTPUT_PATH}/DumpDocumentation
- --all-for-coverage)
+ ADD_TEST(CommandLineTest ${EXECUTABLE_OUTPUT_PATH}/cmaketest
+ ${CMake_SOURCE_DIR}/Tests/CommandLineTest
+ ${CMake_BINARY_DIR}/Tests/CommandLineTest
+ CommandLineTest)
ADD_TEST(CustomCommand ${EXECUTABLE_OUTPUT_PATH}/cmaketest
${CMake_SOURCE_DIR}/Tests/CustomCommand