summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorKen Martin <ken.martin@kitware.com>2004-12-03 14:25:00 (GMT)
committerKen Martin <ken.martin@kitware.com>2004-12-03 14:25:00 (GMT)
commit0ad63cf5fd0f1dfea7bda29fafb8894c6d4ddb54 (patch)
tree852a0038d2b232b87a9fbe8967a91260a100d642 /Source/CMakeLists.txt
parentb1c5f1a7ba343178628dee6217d0059efa691522 (diff)
downloadCMake-0ad63cf5fd0f1dfea7bda29fafb8894c6d4ddb54.zip
CMake-0ad63cf5fd0f1dfea7bda29fafb8894c6d4ddb54.tar.gz
CMake-0ad63cf5fd0f1dfea7bda29fafb8894c6d4ddb54.tar.bz2
ENH: minor fix for windows
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt17
1 files changed, 16 insertions, 1 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 393da3a..b202fff 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -599,6 +599,20 @@ IF(BUILD_TESTING)
--test-command test1
)
+IF (WIN32)
+ ADD_TEST(SubDir ${CMAKE_CTEST_COMMAND}
+ --build-and-test
+ "${CMake_SOURCE_DIR}/Tests/SubDir"
+ "${CMake_BINARY_DIR}/Tests/SubDir"
+ --build-exe-dir "${CMake_BINARY_DIR}/Tests/SubDir/Executable"
+ --build-generator ${CMAKE_GENERATOR}
+ --build-makeprogram ${MAKEPROGRAM}
+ --build-project SUBDIR
+ --test-command test
+ "${CMake_BINARY_DIR}/Tests/SubDir/ShouldBeHere"
+ "${CMake_BINARY_DIR}/Tests/SubDir/testfromsubdir.obj"
+ )
+ELSE (WIN32)
ADD_TEST(SubDir ${CMAKE_CTEST_COMMAND}
--build-and-test
"${CMake_SOURCE_DIR}/Tests/SubDir"
@@ -611,7 +625,8 @@ IF(BUILD_TESTING)
"${CMake_BINARY_DIR}/Tests/SubDir/ShouldBeHere"
"${CMake_BINARY_DIR}/Tests/SubDir/testfromsubdir.o"
)
-
+ENDIF (WIN32)
+
IF(${CMAKE_GENERATOR} MATCHES "Visual Studio")
ADD_TEST(VSExternalInclude ${CMAKE_CTEST_COMMAND}
--build-and-test