summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2006-12-07 15:15:41 (GMT)
committerBill Hoffman <bill.hoffman@kitware.com>2006-12-07 15:15:41 (GMT)
commit1936242ad4b93323ec9d8f4166b2fc63733eba62 (patch)
tree8ea4e7932c69429f5705dd15edecbc7f1ca69200 /Source/CMakeLists.txt
parentba75d1e8232c13ef97416c5f7a909e25abfe1474 (diff)
downloadCMake-1936242ad4b93323ec9d8f4166b2fc63733eba62.zip
CMake-1936242ad4b93323ec9d8f4166b2fc63733eba62.tar.gz
CMake-1936242ad4b93323ec9d8f4166b2fc63733eba62.tar.bz2
ENH: add test I removed by mistake
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index ebb8112..ab2c77e 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -411,6 +411,18 @@ IF(BUILD_TESTING)
${CMake_SOURCE_DIR}/Tests/TargetName/scripts/hello_world
${CMake_BINARY_DIR}/Tests/TargetName/scripts/hello_world)
+ ADD_TEST(LibName ${CMAKE_CTEST_COMMAND}
+ --build-and-test
+ "${CMake_SOURCE_DIR}/Tests/LibName"
+ "${CMake_BINARY_DIR}/Tests/LibName"
+ --build-two-config
+ --build-generator ${CMAKE_TEST_GENERATOR}
+ --build-makeprogram ${CMAKE_TEST_MAKEPROGRAM}
+ --build-project LibName
+ --build-exe-dir "${CMake_BINARY_DIR}/Tests/LibName/lib"
+ --test-command foobar
+ )
+
ADD_TEST(CustComDepend ${CMAKE_CTEST_COMMAND}
--build-and-test
"${CMake_SOURCE_DIR}/Tests/CustComDepend"