summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2015-10-08 17:26:44 (GMT)
committerBrad King <brad.king@kitware.com>2015-10-08 17:26:44 (GMT)
commit265fb0cdc72fc46347ae0b8964078ca6d0a978e1 (patch)
tree02f9cf4b527f2663046099d2cac527c6cd88ebc1 /Source/CMakeLists.txt
parent8083285d1bd5ecc31afa5fa689a9a4ca13ca8bb9 (diff)
downloadCMake-265fb0cdc72fc46347ae0b8964078ca6d0a978e1.zip
CMake-265fb0cdc72fc46347ae0b8964078ca6d0a978e1.tar.gz
CMake-265fb0cdc72fc46347ae0b8964078ca6d0a978e1.tar.bz2
cmFileTimeComparison: Update for lack of cmsys_STAT_HAS_ST_MTIM
The KWSys Configure.hxx header no longer exposes this value. Take the value from the KWSys try compile result variable instead.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index ae5b03f..28a3fd1 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -548,6 +548,18 @@ foreach(v CURL_CA_BUNDLE CURL_CA_PATH)
endif()
endforeach()
+foreach(check
+ STAT_HAS_ST_MTIM
+ )
+ if(KWSYS_CXX_${check}_COMPILED) # abuse KWSys check cache entry
+ set(CMake_${check} 1)
+ else()
+ set(CMake_${check} 0)
+ endif()
+ set_property(SOURCE cmFileTimeComparison.cxx APPEND PROPERTY
+ COMPILE_DEFINITIONS CMake_${check}=${CMake_${check}})
+endforeach()
+
# create a library used by the command line and the GUI
add_library(CMakeLib ${SRCS})
target_link_libraries(CMakeLib cmsys