summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorAndy Cedilnik <andy.cedilnik@kitware.com>2005-01-28 22:14:49 (GMT)
committerAndy Cedilnik <andy.cedilnik@kitware.com>2005-01-28 22:14:49 (GMT)
commit44abd32468a380fefb5d33788514e135b3705ac0 (patch)
treecd03a406ff1596b43a91b873d98127f38b8f925b /Source/CMakeLists.txt
parentab475733e4421869055446b5ab35b8055a1dfb52 (diff)
downloadCMake-44abd32468a380fefb5d33788514e135b3705ac0.zip
CMake-44abd32468a380fefb5d33788514e135b3705ac0.tar.gz
CMake-44abd32468a380fefb5d33788514e135b3705ac0.tar.bz2
ENH: Enable java dependency
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt32
1 files changed, 17 insertions, 15 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 52916fc..7c99a7e 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -1,13 +1,26 @@
CMAKE_MINIMUM_REQUIRED(VERSION 1.5)
SET(SRCS
+ cmBootstrapCommands.cxx
cmCacheManager.cxx
cmCacheManager.h
- cmBootstrapCommands.cxx
cmCommands.cxx
cmCommands.h
cmCustomCommand.cxx
cmCustomCommand.h
+ cmDepends.cxx
+ cmDepends.h
+ cmDependsC.cxx
+ cmDependsC.h
+ cmDependsFortran.cxx
+ cmDependsFortran.h
+ cmDependsFortranLexer.c
+ cmDependsFortranParser.c
+ cmDependsFortranParser.h
+ cmDependsJavaLexer.cxx
+ cmDependsJavaParser.cxx
+ cmDependsJavaParserHelper.cxx
+ cmDependsJavaParserHelper.h
cmDocumentation.cxx
cmDynamicLoader.cxx
cmDynamicLoader.h
@@ -17,6 +30,7 @@ SET(SRCS
cmGlobalGenerator.h
cmGlobalUnixMakefileGenerator.cxx
cmGlobalUnixMakefileGenerator.h
+ cmGlobalXCodeGenerator.cxx
cmListFileCache.cxx
cmListFileCache.h
cmListFileLexer.c
@@ -25,6 +39,7 @@ SET(SRCS
cmLocalUnixMakefileGenerator.cxx
cmLocalUnixMakefileGenerator.h
cmLocalUnixMakefileGenerator2.cxx
+ cmLocalXCodeGenerator.cxx
cmMakeDepend.cxx
cmMakeDepend.h
cmMakefile.cxx
@@ -41,28 +56,15 @@ SET(SRCS
cmVariableWatch.h
cmVersion.cxx
cmVersion.h
+ cmXCodeObject.cxx
cmXMLParser.cxx
cmXMLParser.h
- cmXCodeObject.cxx
- cmLocalXCodeGenerator.cxx
- cmGlobalXCodeGenerator.cxx
cmake.cxx
cmake.h
cmakewizard.cxx
cmakewizard.h
-
- cmDepends.h
- cmDepends.cxx
- cmDependsC.h
- cmDependsC.cxx
- cmDependsFortran.h
- cmDependsFortran.cxx
- cmDependsFortranLexer.c
- cmDependsFortranParser.h
- cmDependsFortranParser.c
)
-
# configure the .h file
CONFIGURE_FILE(
${CMake_SOURCE_DIR}/Source/cmConfigure.cmake.h.in