summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2008-02-07 21:14:05 (GMT)
committerBrad King <brad.king@kitware.com>2008-02-07 21:14:05 (GMT)
commit4987e17f46cb2542106ee2d9afe2752ef78d0f1f (patch)
tree15f70e63f520fb34572ba7147b6231b1e6612276 /Source/CMakeLists.txt
parent0bfad2946dc3da390fed5b58dcf493b55886aa31 (diff)
downloadCMake-4987e17f46cb2542106ee2d9afe2752ef78d0f1f.zip
CMake-4987e17f46cb2542106ee2d9afe2752ef78d0f1f.tar.gz
CMake-4987e17f46cb2542106ee2d9afe2752ef78d0f1f.tar.bz2
ENH: Improve link line generation for static library cycles.
- Move Tarjan algorithm from cmComputeTargetDepends into its own class cmComputeComponentGraph - Use cmComputeComponentGraph to identify the component DAG of link dependencies in cmComputeLinkDepends - Emit non-trivial component members more than once but always in a contiguous group on the link line
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 55dc3a1..bef596e 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -87,6 +87,8 @@ SET(SRCS
cmCommandArgumentLexer.cxx
cmCommandArgumentParser.cxx
cmCommandArgumentParserHelper.cxx
+ cmComputeComponentGraph.cxx
+ cmComputeComponentGraph.h
cmComputeLinkDepends.cxx
cmComputeLinkDepends.h
cmComputeLinkInformation.cxx
@@ -138,6 +140,7 @@ SET(SRCS
cmGlobalGenerator.h
cmGlobalUnixMakefileGenerator3.cxx
cmGlobalUnixMakefileGenerator3.h
+ cmGraphAdjacencyList.h
cmInstallGenerator.h
cmInstallGenerator.cxx
cmInstallExportGenerator.cxx