summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2009-03-16 14:40:46 (GMT)
committerBrad King <brad.king@kitware.com>2009-03-16 14:40:46 (GMT)
commit66d69f864ae880f556debf02e66dee4855b0f2df (patch)
tree562a710c7c071a8dbfd83a15abd35e3a62ec4681 /Source/CMakeLists.txt
parente67f5138b80b3b04844f3f5c0a3c69796266f9e6 (diff)
downloadCMake-66d69f864ae880f556debf02e66dee4855b0f2df.zip
CMake-66d69f864ae880f556debf02e66dee4855b0f2df.tar.gz
CMake-66d69f864ae880f556debf02e66dee4855b0f2df.tar.bz2
ENH: Refactor generation of CTestTestfile content
This moves code which generates ADD_TEST and SET_TESTS_PROPERTIES calls into CTestTestfile.cmake files out of cmLocalGenerator and into a cmTestGenerator class. This will allow more advanced generation without cluttering cmLocalGenerator. The cmTestGenerator class derives from cmScriptGenerator to get support for per-configuration script generation (not yet enabled).
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 89ee0ad..1193363 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -215,6 +215,8 @@ SET(SRCS
cmTarget.h
cmTest.cxx
cmTest.h
+ cmTestGenerator.cxx
+ cmTestGenerator.h
cmVariableWatch.cxx
cmVariableWatch.h
cmVersion.cxx