summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2004-10-11 15:32:14 (GMT)
committerBill Hoffman <bill.hoffman@kitware.com>2004-10-11 15:32:14 (GMT)
commit766c093d69d24200e54d4c7eb22ebeae221ece06 (patch)
tree4f3ba4a5e7c9eee7adb1088c4e9e94e66ef7df87 /Source/CMakeLists.txt
parent4b7f37159314d80321025bc44950e6f623d9cdea (diff)
downloadCMake-766c093d69d24200e54d4c7eb22ebeae221ece06.zip
CMake-766c093d69d24200e54d4c7eb22ebeae221ece06.tar.gz
CMake-766c093d69d24200e54d4c7eb22ebeae221ece06.tar.bz2
NEW: add kdevelop patch from Alexander Neundorf
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index fef89de..5d9b109 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -42,6 +42,7 @@ cmLocalUnixMakefileGenerator.h
cmVariableWatch.h
)
+
# configure the .h file
CONFIGURE_FILE(
${CMake_SOURCE_DIR}/Source/cmConfigure.cmake.h.in
@@ -63,6 +64,14 @@ IF (APPLE)
)
ENDIF (APPLE)
+# Kdevelop only works on UNIX and not windows
+IF(UNIX AND NOT WIN32)
+ SET(SRCS ${SRCS}
+ cmGlobalKdevelopGenerator.cxx
+ cmLocalKdevelopGenerator.cxx)
+ENDIF(UNIX AND NOT WIN32)
+
+
IF (WIN32)
IF(NOT UNIX)
SET(SRCS ${SRCS}