summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2004-03-31 15:01:52 (GMT)
committerBill Hoffman <bill.hoffman@kitware.com>2004-03-31 15:01:52 (GMT)
commitd0cea4c7bb19fecd5b0f7c7636d089a8ef28825b (patch)
treed770b39b441c777d12a6c8127966549cd9bf8860 /Source/CMakeLists.txt
parentd1185c59104565a96026ee78498f8739b77b2b3c (diff)
downloadCMake-d0cea4c7bb19fecd5b0f7c7636d089a8ef28825b.zip
CMake-d0cea4c7bb19fecd5b0f7c7636d089a8ef28825b.tar.gz
CMake-d0cea4c7bb19fecd5b0f7c7636d089a8ef28825b.tar.bz2
ENH: make relative paths optional and default off, and add a test for them
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index bff099f..310e38a 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -322,6 +322,17 @@ IF(BUILD_TESTING)
--build-exe-dir "${CMake_BINARY_DIR}/Tests/ComplexOneConfig/bin"
--test-command complex)
+ ADD_TEST(complexRelativePaths ${CMAKE_CTEST_COMMAND}
+ --build-and-test
+ "${CMake_SOURCE_DIR}/Tests/Complex"
+ "${CMake_BINARY_DIR}/Tests/ComplexRelativePaths"
+ --build-generator ${CMAKE_GENERATOR}
+ --build-project complex
+ --build-makeprogram ${MAKEPROGRAM}
+ --build-exe-dir "${CMake_BINARY_DIR}/Tests/ComplexRelativePaths/bin"
+ --build-options -DCMAKE_USE_RELATIVE_PATHS:BOOL=ON
+ --test-command complex)
+
ENDIF(NOT COMPILER_IS_COMO)
ADD_TEST(Example ${CMAKE_CTEST_COMMAND}