summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorPatrick Gansterer <paroga@paroga.com>2012-11-19 14:48:33 (GMT)
committerBrad King <brad.king@kitware.com>2012-11-19 17:54:30 (GMT)
commite8f841473bcefc618ddf6712567e624156e88399 (patch)
tree2c77a631bcf9ee7c0cf731354db30c87a1cae312 /Source/CMakeLists.txt
parent3359d95c00c221328d284e443c1d49e12630be63 (diff)
downloadCMake-e8f841473bcefc618ddf6712567e624156e88399.zip
CMake-e8f841473bcefc618ddf6712567e624156e88399.tar.gz
CMake-e8f841473bcefc618ddf6712567e624156e88399.tar.bz2
Introduce the abstract class cmGlobalGeneratorFactory
This new abstract class allows us move some logic from the cmGlobalGenerator into its own layer in a next step.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 8bf6c40..7bf1678 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -201,6 +201,7 @@ set(SRCS
cmGeneratorTarget.h
cmGlobalGenerator.cxx
cmGlobalGenerator.h
+ cmGlobalGeneratorFactory.h
cmGlobalUnixMakefileGenerator3.cxx
cmGlobalUnixMakefileGenerator3.h
cmGraphAdjacencyList.h