summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Neundorf <neundorf@kde.org>2007-07-18 14:19:33 (GMT)
committerAlexander Neundorf <neundorf@kde.org>2007-07-18 14:19:33 (GMT)
commit27244a1fdef646ea791e28119cefc57c4c967564 (patch)
tree6ed62309ee34fb3e01646a301acf9939c4414b7b /Source/CMakeLists.txt
parent0044ce71bce5e9329356d0cb6bc67ea30142b9b2 (diff)
downloadCMake-27244a1fdef646ea791e28119cefc57c4c967564.zip
CMake-27244a1fdef646ea791e28119cefc57c4c967564.tar.gz
CMake-27244a1fdef646ea791e28119cefc57c4c967564.tar.bz2
ENH: build codeblocks generator also on Windows
Alex
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt9
1 files changed, 6 insertions, 3 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 574e69d..915097e 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -173,10 +173,13 @@ SET(SRCS
# Kdevelop only works on UNIX and not windows
IF(UNIX)
- SET(SRCS ${SRCS}
- cmGlobalKdevelopGenerator.cxx
- cmExtraCodeBlocksGenerator.cxx)
+ SET(SRCS ${SRCS} cmGlobalKdevelopGenerator.cxx)
ENDIF(UNIX)
+
+IF(NOT CYGWIN)
+ SET(SRCS ${SRCS} cmExtraCodeBlocksGenerator.cxx)
+ENDIF(NOT CYGWIN)
+
# XCode only works on apple
IF(APPLE)
SET(SRCS ${SRCS}