summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorKonstantin Podsvirov <konstantin@podsvirov.pro>2017-04-27 20:51:00 (GMT)
committerBrad King <brad.king@kitware.com>2017-05-03 15:32:05 (GMT)
commit9c13e8eb6fcc249afaf905d67e24b63884c4aa2f (patch)
treed120100d80cfaee00c0e369c00dddb1bee27c9c7 /Source/CMakeLists.txt
parent96820279541017402c1fe0852444aac68179ddb7 (diff)
downloadCMake-9c13e8eb6fcc249afaf905d67e24b63884c4aa2f.zip
CMake-9c13e8eb6fcc249afaf905d67e24b63884c4aa2f.tar.gz
CMake-9c13e8eb6fcc249afaf905d67e24b63884c4aa2f.tar.bz2
CPackIFW: Refactor out some commonly used code
Move common used code to new cmCPackIFWCommon base class.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt17
1 files changed, 13 insertions, 4 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 1ea75bf..40403ca 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -867,10 +867,6 @@ set(CPACK_SRCS
CPack/cmCPackGenerator.cxx
CPack/cmCPackLog.cxx
CPack/cmCPackNSISGenerator.cxx
- CPack/IFW/cmCPackIFWPackage.cxx
- CPack/IFW/cmCPackIFWInstaller.cxx
- CPack/IFW/cmCPackIFWRepository.cxx
- CPack/IFW/cmCPackIFWGenerator.cxx
CPack/cmCPackSTGZGenerator.cxx
CPack/cmCPackTGZGenerator.cxx
CPack/cmCPackTXZGenerator.cxx
@@ -879,6 +875,19 @@ set(CPACK_SRCS
CPack/cmCPackZIPGenerator.cxx
CPack/cmCPack7zGenerator.cxx
)
+# CPack IFW generator
+set(CPACK_SRCS ${CPACK_SRCS}
+ CPack/IFW/cmCPackIFWCommon.cxx
+ CPack/IFW/cmCPackIFWCommon.h
+ CPack/IFW/cmCPackIFWGenerator.cxx
+ CPack/IFW/cmCPackIFWGenerator.h
+ CPack/IFW/cmCPackIFWInstaller.cxx
+ CPack/IFW/cmCPackIFWInstaller.h
+ CPack/IFW/cmCPackIFWPackage.cxx
+ CPack/IFW/cmCPackIFWPackage.h
+ CPack/IFW/cmCPackIFWRepository.cxx
+ CPack/IFW/cmCPackIFWRepository.h
+ )
if(CYGWIN)
set(CPACK_SRCS ${CPACK_SRCS}