summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2009-07-29 15:29:08 (GMT)
committerBrad King <brad.king@kitware.com>2009-07-29 15:29:08 (GMT)
commit5b85a581a88a56aed7ed7e16637b9d349629bdcf (patch)
treed47f0321096777a9cb752a8330c01ba01336209d /Source/CMakeLists.txt
parente339f3133fdc712e71a1bd45bdf051baa2fe6fdb (diff)
downloadCMake-5b85a581a88a56aed7ed7e16637b9d349629bdcf.zip
CMake-5b85a581a88a56aed7ed7e16637b9d349629bdcf.tar.gz
CMake-5b85a581a88a56aed7ed7e16637b9d349629bdcf.tar.bz2
ENH: Separate option mapping from VS generators
Split cmVisualStudioGeneratorOptions core functionality out into a base class cmIDEOptions. It will be useful for other generators.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index fed4d74..55048a3 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -296,6 +296,8 @@ IF (WIN32)
cmGlobalVisualStudioGenerator.h
cmGlobalWatcomWMakeGenerator.cxx
cmIDEFlagTable.h
+ cmIDEOptions.cxx
+ cmIDEOptions.h
cmLocalVisualStudio6Generator.cxx
cmLocalVisualStudio6Generator.h
cmLocalVisualStudio7Generator.cxx