summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Neundorf <neundorf@kde.org>2007-08-14 12:40:40 (GMT)
committerAlexander Neundorf <neundorf@kde.org>2007-08-14 12:40:40 (GMT)
commitdfbd4ce0f2ec91689566a8c965d7be5a6833af56 (patch)
tree56d15bb7c2c09ea7db96c43d68fceb009a6c9d09 /Source/CMakeLists.txt
parentfbf502519203ca5d90387f66300802ceb1c97107 (diff)
downloadCMake-dfbd4ce0f2ec91689566a8c965d7be5a6833af56.zip
CMake-dfbd4ce0f2ec91689566a8c965d7be5a6833af56.tar.gz
CMake-dfbd4ce0f2ec91689566a8c965d7be5a6833af56.tar.bz2
ENH: deb generator: don't use the system provided ar, but do it yourself
using the code from OpenBSD ar COMP: don't build all package generators on all platforms Alex
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt28
1 files changed, 22 insertions, 6 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 1ca897c..8496bc3 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -295,18 +295,34 @@ SET(CPACK_SRCS
CPack/cmCPackGenericGenerator.cxx
CPack/cmCPackLog.cxx
CPack/cmCPackNSISGenerator.cxx
- CPack/cmCPackOSXX11Generator.cxx
- CPack/cmCPackPackageMakerGenerator.cxx
CPack/cmCPackSTGZGenerator.cxx
CPack/cmCPackTGZGenerator.cxx
CPack/cmCPackTarBZip2Generator.cxx
CPack/cmCPackTarCompressGenerator.cxx
CPack/cmCPackZIPGenerator.cxx
- CPack/cmCPackCygwinBinaryGenerator.cxx
- CPack/cmCPackCygwinSourceGenerator.cxx
- CPack/cmCPackDebGenerator.cxx
- CPack/cmCPackRPMGenerator.cxx
)
+
+IF(WIN32 AND UNIX)
+ SET(CPACK_SRCS ${CPACK_SRCS}
+ CPack/cmCPackCygwinBinaryGenerator.cxx
+ CPack/cmCPackCygwinSourceGenerator.cxx
+ )
+ENDIF(WIN32 AND UNIX)
+
+IF(UNIX)
+ SET(CPACK_SRCS ${CPACK_SRCS}
+ CPack/cmCPackDebGenerator.cxx
+ CPack/cmCPackRPMGenerator.cxx
+ )
+ENDIF(UNIX)
+
+IF(APPLE)
+ SET(CPACK_SRCS ${CPACK_SRCS}
+ CPack/cmCPackOSXX11Generator.cxx
+ CPack/cmCPackPackageMakerGenerator.cxx
+ )
+ENDIF(APPLE)
+
# Build CPackLib
ADD_LIBRARY(CPackLib ${CPACK_SRCS})
TARGET_LINK_LIBRARIES(CPackLib CMakeLib)