summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorAndy Cedilnik <andy.cedilnik@kitware.com>2004-02-08 17:04:10 (GMT)
committerAndy Cedilnik <andy.cedilnik@kitware.com>2004-02-08 17:04:10 (GMT)
commite72bac587054b16fdc44ed597b7f03b06656d95a (patch)
tree921a8c0fd5c7fba24882be9b4013a62ffe9de55e /Source/CMakeLists.txt
parent31c1071ebfb559ba4d0cd113e54f85d9e2228d77 (diff)
downloadCMake-e72bac587054b16fdc44ed597b7f03b06656d95a.zip
CMake-e72bac587054b16fdc44ed597b7f03b06656d95a.tar.gz
CMake-e72bac587054b16fdc44ed597b7f03b06656d95a.tar.bz2
ENH: Add second part of SimpleInstall
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 5a8aad2..c1bb7c6 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -251,6 +251,19 @@ IF(BUILD_TESTING)
--build-options
"-DCMAKE_INSTALL_PREFIX:PATH=${SimpleInstallInstallDir}"
--test-command ${SimpleInstallInstallDir}/bin/SimpleInstall)
+ ADD_TEST(SimpleInstall-Stage2 ${CMAKE_CTEST_COMMAND}
+ --build-and-test
+ "${CMake_SOURCE_DIR}/Tests/SimpleInstall"
+ "${CMake_BINARY_DIR}/Tests/SimpleInstallS2"
+ --build-generator ${CMAKE_GENERATOR}
+ --build-project TestSimpleInstall
+ --build-makeprogram ${MAKEPROGRAM}
+ --build-two-config
+ --build-options
+ "-DCMAKE_INSTALL_PREFIX:PATH=${SimpleInstallInstallDir}"
+ "-DSTAGE2:BOOL=1"
+ --test-command
+ ${CMake_BINARY_DIR}/Tests/SimpleInstallS2/ExecPath/SimpleInstallS2)
ADD_TEST(X11 ${CMAKE_CTEST_COMMAND}
--build-and-test