summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorKen Martin <ken.martin@kitware.com>2007-02-27 15:10:10 (GMT)
committerKen Martin <ken.martin@kitware.com>2007-02-27 15:10:10 (GMT)
commit31a700188b6864341fdcbd22cd4181dbe6ace671 (patch)
treed1fafeb509092de727a1b977ffb9071ea1d966a8 /Source/CMakeLists.txt
parentfa9f03779f5cbfcd6ee264fcf6989e571779a156 (diff)
downloadCMake-31a700188b6864341fdcbd22cd4181dbe6ace671.zip
CMake-31a700188b6864341fdcbd22cd4181dbe6ace671.tar.gz
CMake-31a700188b6864341fdcbd22cd4181dbe6ace671.tar.bz2
ENH: added --system-information option to CMake
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 44d50da..a63df3e 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -505,6 +505,11 @@ IF(BUILD_TESTING)
--build-makeprogram ${CMAKE_TEST_MAKEPROGRAM}
--test-command DumpInformation)
+ ADD_TEST(SystemInformationNew
+ ${CMAKE_CMAKE_COMMAND} -E chdir "${CMake_BINARY_DIR}"
+ ${CMAKE_CMAKE_COMMAND} --system-information
+ )
+
ADD_TEST(StringFileTest ${CMAKE_CTEST_COMMAND}
--build-and-test
"${CMake_SOURCE_DIR}/Tests/StringFileTest"