summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorAndy Cedilnik <andy.cedilnik@kitware.com>2007-02-23 14:46:27 (GMT)
committerAndy Cedilnik <andy.cedilnik@kitware.com>2007-02-23 14:46:27 (GMT)
commit8ad343093179035fa8ad9136e8e8f72fc3804dd2 (patch)
tree35c34abc3af73da857cffea26f0c4eeb2872369b /Source/CMakeLists.txt
parent440bbf08711e9a784f90f1d2541e5d204807161a (diff)
downloadCMake-8ad343093179035fa8ad9136e8e8f72fc3804dd2.zip
CMake-8ad343093179035fa8ad9136e8e8f72fc3804dd2.tar.gz
CMake-8ad343093179035fa8ad9136e8e8f72fc3804dd2.tar.bz2
ENH: Make EXCLUDE_FROM_ALL a target and directory properties. Also, make IsInAll use EXCLUDE_FROM_ALL. Also, enable the test that tests this
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 4346752..213c631 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -545,6 +545,19 @@ IF(BUILD_TESTING)
--build-two-config
--test-command simple)
+ ADD_TEST(SimpleExclude ${CMAKE_CTEST_COMMAND}
+ --build-and-test
+ "${CMake_SOURCE_DIR}/Tests/SimpleExclude"
+ "${CMake_BINARY_DIR}/Tests/SimpleExclude"
+ --build-generator ${CMAKE_TEST_GENERATOR}
+ --build-project SimpleExclude
+ --build-makeprogram ${CMAKE_TEST_MAKEPROGRAM}
+ --build-two-config
+ --test-command "${CMAKE_COMMAND}"
+ "-DCONFIGURATION=\${CTEST_CONFIGURATION_TYPE}"
+ -P "${CMAKE_BINARY_DIR}/Tests/SimpleExclude/run.cmake"
+ )
+
# ADD_TEST(SameName ${CMAKE_CTEST_COMMAND}
# --build-and-test
# "${CMake_SOURCE_DIR}/Tests/SameName"