summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorKonstantin Podsvirov <konstantin@podsvirov.pro>2016-08-04 10:01:42 (GMT)
committerKonstantin Podsvirov <konstantin@podsvirov.pro>2016-08-16 16:02:35 (GMT)
commitc18dc6fbe5b68312be52353aa0a493106584ffe7 (patch)
treeaef64221386463a3acc980f946b65a8f6292cbe5 /Source/CMakeLists.txt
parent6b07972fbdf7e8687577a430597e40e7e0b4831d (diff)
downloadCMake-c18dc6fbe5b68312be52353aa0a493106584ffe7.zip
CMake-c18dc6fbe5b68312be52353aa0a493106584ffe7.tar.gz
CMake-c18dc6fbe5b68312be52353aa0a493106584ffe7.tar.bz2
Added CMake_BUILD_DEVELOPER_REFERENCE option
By default is OFF and marked as advanced. It's also add custom cmake-developer-reference (ALL) target Generated output will be installed to ${CMAKE_DOC_DIR}/developer-reference.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index cdc8fb1..b68675d 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -50,6 +50,15 @@ if(WIN32)
add_definitions(-DUNICODE -D_UNICODE)
endif()
+# configure the .dox.in file
+if(CMake_BUILD_DEVELOPER_REFERENCE)
+ configure_file(
+ "${CMake_SOURCE_DIR}/Source/dir.dox.in"
+ "${CMake_BINARY_DIR}/Source/dir.dox"
+ @ONLY
+ )
+endif()
+
# configure the .h file
configure_file(
"${CMake_SOURCE_DIR}/Source/cmConfigure.cmake.h.in"