summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2018-09-25 23:25:34 (GMT)
committerBrad King <brad.king@kitware.com>2018-12-11 18:19:39 (GMT)
commit410a3e4b22c72794d4f96e41c1d37d84d6e7e54d (patch)
treedd7c623d4326a2d7f641fc9748045090679a2a0e /Source/CMakeLists.txt
parent81bea69bd1d52977c3782d26560f34563394f487 (diff)
downloadCMake-410a3e4b22c72794d4f96e41c1d37d84d6e7e54d.zip
CMake-410a3e4b22c72794d4f96e41c1d37d84d6e7e54d.tar.gz
CMake-410a3e4b22c72794d4f96e41c1d37d84d6e7e54d.tar.bz2
Add support for using C++17 string_view or a fallback
Define a `cm::string_view` type implemented via C++17 `std::string_view` when available. Provide a fallback implementation for C++11 and C++14 compilers. The fallback implementation was written by reading documentation of the standard spec. We have no dedicated tests for it, but it will be covered by tests of its clients later.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 9aebfa7..4bf2e73 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -375,6 +375,8 @@ set(SRCS
cmXMLWriter.h
cmake.cxx
cmake.h
+ cm_string_view.cxx
+ cm_string_view.hxx
cmCommand.cxx
cmCommand.h