summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorChuck Atkins <chuck.atkins@kitware.com>2019-01-28 21:28:28 (GMT)
committerBrad King <brad.king@kitware.com>2019-01-29 11:59:24 (GMT)
commit475e78d9071b34690617a85853433a9fc15da057 (patch)
tree2e3fe9aa6bd1d493276e5451a8b4a7fa9db45672 /Source/CMakeLists.txt
parent8887ebc69b86606b388272d5c89ce11753bb4804 (diff)
downloadCMake-475e78d9071b34690617a85853433a9fc15da057.zip
CMake-475e78d9071b34690617a85853433a9fc15da057.tar.gz
CMake-475e78d9071b34690617a85853433a9fc15da057.tar.bz2
macOS: Add missing explicit dependency on CoreServices framework
On Apple, the implementation of cmGlobalXCodeGenerator::Open uses LSOpenCFURLRef from CoreServices. This get's transitively pulled in from CMake's libuv build but ends up generating a linker error when using an external libuv. This explicitly adds the appropriate dependency.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 311f3f4..8aff8f6 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -791,9 +791,10 @@ if(CMAKE_SYSTEM_NAME STREQUAL "Linux" AND CMAKE_SYSTEM_PROCESSOR MATCHES "sparc"
endif()
endif()
-# On Apple we need CoreFoundation
+# On Apple we need CoreFoundation and CoreServices
if(APPLE)
target_link_libraries(CMakeLib "-framework CoreFoundation")
+ target_link_libraries(CMakeLib "-framework CoreServices")
endif()
if(WIN32 AND NOT UNIX)