summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBen Boeckel <ben.boeckel@kitware.com>2018-01-09 13:40:48 (GMT)
committerBen Boeckel <ben.boeckel@kitware.com>2018-01-10 16:21:11 (GMT)
commitb0716fbcc5be83ecd082e8b6d101f1137d6f16f8 (patch)
treef93425efeb3e11cb4cd2af9c771e1b5632571fa9 /Source/CMakeLists.txt
parentddc4f9a3c05fa24240fde1ba6c0ab28b7d2e91ea (diff)
downloadCMake-b0716fbcc5be83ecd082e8b6d101f1137d6f16f8.zip
CMake-b0716fbcc5be83ecd082e8b6d101f1137d6f16f8.tar.gz
CMake-b0716fbcc5be83ecd082e8b6d101f1137d6f16f8.tar.bz2
cmSourceFileLocation: allow skipping ambiguous extensions
The ambiguous extension logic is an old behavior that ends up taking lots of extra compute cycles to execute. This is triggered by various CMake codepaths which pass extension-less paths down when CMake actually knows that they are not ambiguous. These codepaths will be indicated in upcoming changes. Various APIs have gained a cmSourceFileLocationKind parameter, but they are all optional and default to the existing behavior.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 7031d5a..1b46377 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -327,6 +327,7 @@ set(SRCS
cmSourceFile.h
cmSourceFileLocation.cxx
cmSourceFileLocation.h
+ cmSourceFileLocationKind.h
cmSourceGroup.cxx
cmSourceGroup.h
cmState.cxx