summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2019-01-29 13:59:32 (GMT)
committerKitware Robot <kwrobot@kitware.com>2019-01-29 13:59:59 (GMT)
commiteeb34232fc2b76dc8b9bde25b2ca696d91b51b5a (patch)
tree3e03fae34422c6e6be84e168b026dd4c8baa4e62 /Source/CMakeLists.txt
parentbcb1297faf4e4f7bab665b80bc49b8bbabf33a9f (diff)
parent475e78d9071b34690617a85853433a9fc15da057 (diff)
downloadCMake-eeb34232fc2b76dc8b9bde25b2ca696d91b51b5a.zip
CMake-eeb34232fc2b76dc8b9bde25b2ca696d91b51b5a.tar.gz
CMake-eeb34232fc2b76dc8b9bde25b2ca696d91b51b5a.tar.bz2
Merge topic 'add-missing-macos-framework'
475e78d907 macOS: Add missing explicit dependency on CoreServices framework Acked-by: Kitware Robot <kwrobot@kitware.com> Merge-request: !2873
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index c73c6df..1c06052 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -819,9 +819,10 @@ if(CMAKE_SYSTEM_NAME STREQUAL "Linux" AND CMAKE_SYSTEM_PROCESSOR MATCHES "sparc"
endif()
endif()
-# On Apple we need CoreFoundation
+# On Apple we need CoreFoundation and CoreServices
if(APPLE)
target_link_libraries(CMakeLib "-framework CoreFoundation")
+ target_link_libraries(CMakeLib "-framework CoreServices")
endif()
if(WIN32 AND NOT UNIX)