summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2016-09-29 17:18:47 (GMT)
committerBrad King <brad.king@kitware.com>2016-09-29 17:20:10 (GMT)
commita8334961997767ecc31333b52537aa5e5b6c561c (patch)
tree4b63eb0ce11abef1b78f1cd9498009364f2e57cb /Source/CMakeLists.txt
parent97b6e17c336f36556981e9371af78f08f4d304bb (diff)
downloadCMake-a8334961997767ecc31333b52537aa5e5b6c561c.zip
CMake-a8334961997767ecc31333b52537aa5e5b6c561c.tar.gz
CMake-a8334961997767ecc31333b52537aa5e5b6c561c.tar.bz2
server-mode: Rename variable CMake_{HAVE => ENABLE}_SERVER_MODE
The latter is a better name for making it a public-facing option.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index b8f02e3..2641381 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -778,7 +778,7 @@ add_executable(cmake cmakemain.cxx cmcmd.cxx cmcmd.h ${MANIFEST_FILE})
list(APPEND _tools cmake)
target_link_libraries(cmake CMakeLib)
-if(CMake_HAVE_SERVER_MODE)
+if(CMake_ENABLE_SERVER_MODE)
add_library(CMakeServerLib
cmServer.cxx cmServer.h
cmServerConnection.cxx cmServerConnection.h