summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorSean McBride <sean@rogue-research.com>2016-03-17 14:47:44 (GMT)
committerBrad King <brad.king@kitware.com>2016-03-17 17:53:51 (GMT)
commitc718070c0887e1c429d6ae4b717c006236c32736 (patch)
treea14c20a6cc6262a32be6f101c9ee29de55411b1f /Source/CMakeLists.txt
parentb369959eb55dbea601315530185cb480c922cc77 (diff)
downloadCMake-c718070c0887e1c429d6ae4b717c006236c32736.zip
CMake-c718070c0887e1c429d6ae4b717c006236c32736.tar.gz
CMake-c718070c0887e1c429d6ae4b717c006236c32736.tar.bz2
CPack: Avoid requiring Carbon framework on OS X (#16021)
In commit v3.5.0-rc1~232^2 (CPackDMG: Add support for multilingual SLAs, 2015-10-19) we added use of the Carbon framework in order to get access to its APIs to convert Script Manager RegionCode values. This is not necessary. Instead we can use CoreServices. While at it, replace individual CoreFoundation includes with including the entire framework, which is the correct way.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index ab70568..5b67a2d 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -728,7 +728,7 @@ endif()
add_library(CPackLib ${CPACK_SRCS})
target_link_libraries(CPackLib CMakeLib)
if(APPLE)
- target_link_libraries(CPackLib "-framework Carbon")
+ target_link_libraries(CPackLib "-framework CoreServices")
endif()
if(APPLE)