summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2015-02-06 18:23:07 (GMT)
committerBrad King <brad.king@kitware.com>2015-02-06 18:32:57 (GMT)
commitcd408d93fdf347ff63a8062f75f1f4ee3e898b17 (patch)
tree8fe5fcf05cd8092ccb1b80b0879c3928bec2af82 /Source/CMakeLists.txt
parent87be2e1427ba2b1b7697c9332487862917897dca (diff)
downloadCMake-cd408d93fdf347ff63a8062f75f1f4ee3e898b17.zip
CMake-cd408d93fdf347ff63a8062f75f1f4ee3e898b17.tar.gz
CMake-cd408d93fdf347ff63a8062f75f1f4ee3e898b17.tar.bz2
Add setlocale() calls around use of libarchive APIs (#14934, #15377)
The libarchive APIs use nl_langinfo(CODESET) for iconv so they need the locale to be set for LC_CTYPE. However, the rest of CMake does not define any behavior for non-ASCII character classification/conversion so we do not want to setlocale() globally. Add a RAII class to save, set, and restore the locale around calls to libarchive APIs. Inspired-by: Clinton Stimpson <clinton@elemtech.com>
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index f9405b3..1ff1c16 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -261,6 +261,7 @@ set(SRCS
cmLocalGenerator.cxx
cmLocalGenerator.h
cmLocalUnixMakefileGenerator3.cxx
+ cmLocale.h
cmMakeDepend.cxx
cmMakeDepend.h
cmMakefile.cxx