summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorJiri Malak <malak.jiri@gmail.com>2014-03-17 18:30:38 (GMT)
committerBrad King <brad.king@kitware.com>2014-03-17 19:04:05 (GMT)
commit64c2342a8d0f3e655349d3897d2dee46a89aaedc (patch)
treeb42e5f4a9eedb561eede784e0f3174024f6dd507 /Source/CMakeLists.txt
parent5d9aa66c91909b8d7eab16edb020c9a14205ba69 (diff)
downloadCMake-64c2342a8d0f3e655349d3897d2dee46a89aaedc.zip
CMake-64c2342a8d0f3e655349d3897d2dee46a89aaedc.tar.gz
CMake-64c2342a8d0f3e655349d3897d2dee46a89aaedc.tar.bz2
Watcom: Enable 'WMake Makefiles' generator on Linux
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 9fb8d9a..762470f 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -404,7 +404,6 @@ if (WIN32)
cmGlobalVisualStudio12Generator.cxx
cmGlobalVisualStudioGenerator.cxx
cmGlobalVisualStudioGenerator.h
- cmGlobalWatcomWMakeGenerator.cxx
cmIDEFlagTable.h
cmIDEOptions.cxx
cmIDEOptions.h
@@ -424,6 +423,15 @@ if (WIN32)
endif()
endif ()
+# Watcom support
+if(WIN32 OR "${CMAKE_SYSTEM_NAME}" STREQUAL "Linux")
+ set_property(SOURCE cmake.cxx APPEND PROPERTY COMPILE_DEFINITIONS CMAKE_USE_WMAKE)
+ list(APPEND SRCS
+ cmGlobalWatcomWMakeGenerator.cxx
+ cmGlobalWatcomWMakeGenerator.h
+ )
+endif()
+
# Ninja support
set(SRCS ${SRCS}
cmGlobalNinjaGenerator.cxx