summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2018-09-21 15:11:36 (GMT)
committerBrad King <brad.king@kitware.com>2018-09-21 15:39:59 (GMT)
commit72b4c2c48ae7dfd8c2813018c72ed0d2e6bb907a (patch)
tree11976bcd9d3e5da19fa1151eeb05389f7796e846 /Source/CMakeLists.txt
parentb48165346f7dfcd025beca743abf2eaf849bf17d (diff)
downloadCMake-72b4c2c48ae7dfd8c2813018c72ed0d2e6bb907a.zip
CMake-72b4c2c48ae7dfd8c2813018c72ed0d2e6bb907a.tar.gz
CMake-72b4c2c48ae7dfd8c2813018c72ed0d2e6bb907a.tar.bz2
server: Compile json object generation source separately
Declare entry points in a dedicated header and compile the source separately instead of including it in the server implementation.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 628cc6f..bfddbc6 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -1047,6 +1047,9 @@ target_link_libraries(cmake CMakeLib)
add_library(CMakeServerLib
cmConnection.h cmConnection.cxx
cmFileMonitor.cxx cmFileMonitor.h
+ cmJsonObjectDictionary.h
+ cmJsonObjects.h
+ cmJsonObjects.cxx
cmPipeConnection.cxx cmPipeConnection.h
cmServer.cxx cmServer.h
cmServerConnection.cxx cmServerConnection.h