summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2006-01-23 18:50:23 (GMT)
committerBill Hoffman <bill.hoffman@kitware.com>2006-01-23 18:50:23 (GMT)
commit7f237c51f413a350090e68929eee9f8380c5bcfe (patch)
treeab344979e827483f3dc063217c7a432f2e1e2b0e /Source/CMakeLists.txt
parent5c692ee247bb79eacc71350524d60a19dac80903 (diff)
downloadCMake-7f237c51f413a350090e68929eee9f8380c5bcfe.zip
CMake-7f237c51f413a350090e68929eee9f8380c5bcfe.tar.gz
CMake-7f237c51f413a350090e68929eee9f8380c5bcfe.tar.bz2
ENH: fix problem with watcom and short paths and -I
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 52cf699..0318d05 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -564,7 +564,9 @@ IF(BUILD_TESTING)
--build-generator ${CMAKE_TEST_GENERATOR}
--build-project complex
--build-makeprogram ${CMAKE_TEST_MAKEPROGRAM}
- --build-exe-dir "${CMake_BINARY_DIR}/Tests/ComplexOneConfig/bin"
+ --build-exe-dir "${CMake_BINARY_DIR}/Tests/ComplexOneConfig/bin"
+ --build-options
+ -DCMAKE_TEST_DIFFERENT_GENERATOR:BOOL=${CMAKE_TEST_DIFFERENT_GENERATOR}
--test-command complex)
# ADD_TEST(complexRelativePaths ${CMAKE_CTEST_COMMAND}